Jump to content

Atwood furnace 2002 Diplomat


Recommended Posts

Atwood furnace cycles 3 times then shuts off.

Worked fine last time out.

Needed to do some work inside today and this is what greeted me. Fan works and gas ignites 3 times and quits fan continues to run. Any Ideas?

Link to comment
Share on other sites

Not knowing the particular unit but it sounds like it is trying to light, a safety sensor is triggering, the system tries two more times and then goes to lock out.

So, you will have to figure out what sensor is not happy and resolve that issue.

Since it's a short cycle, sounds like some kind of flame sensor not seeing the furnace lighting.  But that's just a guess.

  • Like 1
Link to comment
Share on other sites

Most likely the sail switch is bad. Common problem. The fan blows air against it allowing the furnace to continue to run. If the switch fails it shuts the furnace off. Not hard to fix. I suggest a YouTube search on your model.

  • Like 1
Link to comment
Share on other sites

9 minutes ago, Mark B said:

Most likely the sail switch is bad. Common problem. The fan blows air against it allowing the furnace to continue to run. If the switch fails it shuts the furnace off. Not hard to fix. I suggest a YouTube search on your model.

Thanks, will try the switch

Link to comment
Share on other sites

10 minutes ago, Gary 05 AMB DST said:

The switch isn't always defective. There could be some lint on the switch preventing it from opening. The switch is accessible from the outside.

Gary 05 AMB DST

Got it. Dirt on the switch was the cause. Thanks for the help. I was just over complicated it.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...