Jump to content

Step Well Lights no +12V (2000 Monaco Windsor)


Ali-026
 Share

Go to solution Solved by jacwjames,

Recommended Posts

I lost +12V for the step well lights. The switch provides the ground and there should be a constant +12V. I checked front electrical box for a blown fuse, but there was none. Actually there seem to be no dedicated fuse for step well lights. I've tried tracing the wires but could not see where they are going. 

Does anyone know where step lights get their +12V by any chance?

Thank you

Ali

step well lights.jpg

elec-panel.jpg

Link to comment
Share on other sites

I think the fuse for this is in your 12 volt distribution panel, mine is located in the bedroom. 

I searched my wiring diagram and it shows up there but it is not specific as to which fuse it may be associated with. 

My grab bar handle is lighted and it is on the same switch, do you have a lighted grab bar??? 

Not sure how these wires are routed, I went through the same thing last year when I replaced the step lights.  At that time I didn't know the circuit was controlled by a negative (-) switch.  I started to try and trace the wires but then found out about the switching. 

I'll check mine later and see what I find.

Link to comment
Share on other sites

I would test each fuse in your Front Run Bay aka FRB as it may not be labeled exactly what you would expect OR it may be added onto a circuit labeled something entirely different.

Test the ones in the bedroom (if that's where they are) too. I posted a photo of the bedroom layout in the 02 Windsor that I had owned. Sounds like it may be different than what Jim has in his Windsor, not surprised.

Domestic 12 VDC Fuse Descriptions.jpg

Link to comment
Share on other sites

I was wrong on both counts.  The grab bar is turned on with the step light.  The step well lights are not on the 12 volt house panel, I used the saleman switch to turn the house power off and the step well lights stayed on so they are associated with the chassis power of 12 volt house side in the front run bay.  They may be wired on the same circuit as the step or service lights,  You'll just have to start pulling fuses and check.

Link to comment
Share on other sites

  • Solution

OK

I went and checked mine and the step lights are controlled by the fuse labeled Service Lts,  Not sure what that all includes.  It is a 15 amp fuse in the #6 slot, yours may be different. 

If the fuse is good I'd check the step lights themselves to make sure the bulb isn't burned out and that the wire nuts and ground connections are good. 

Link to comment
Share on other sites

That was it 🎯 The 15 amp fuse in the #6 slot was the culprit. When I was inspecting the fuses I did not see fuses #5 and 6 as they were hiding behind a bunch of wires. After replacing the broken fuse with a new 15 amp, all is working again 😀

Jim, Richard, thank soo much for all your help. You guys saved me a lot of time and frustration. Interestingly I was just working on improving ground connections behind the dash few weeks ago when I noticed step well lights not working. I first checked FRB but overlooked #6 thinking it wasn't the fuse but me poking around the dash. I spent hours trying to figure it out. I am so happy that I was able to fix the issue now. 

Lesson learned: know your RV, know your fuses. If you are stuck, ask the good folks at Monaco'ers 🚍  

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...