Jump to content

Intellitec EMS issue


Recommended Posts

We have an Intellitec 50 AMP Smart Energy Management System (EMS) Model 750. We are currently plugged into a good (verified by Progressive PT50C)  30A receptacle. At one point our EMS indicated a 50A source rather than 30. I started the generator and the panel correctly indicated "GEN SET", but when I killed the gennie it went back to indicating 50A.

I was able to reset it by killing all power (AC and DC), waiting a bit, then re-establishing power. It indicated normally for a day or so, then went back to the 50A indication. I tried the reset procedure again, twice, but this time it didn't help.

So my questions are, what causes this malfunction, and how can I fix it? Do I need a new control board?

Thanks.

Jim

Link to comment
Share on other sites

Disregard. Problem solved. I found a post on IRV2 which said all circuit breakers must be on for the EMS panel to function normally. I had turned off the circuit breaker for the front A/C because it is running continuously (another issue; stuck relay maybe?). I turned that breaker back on and the EMS panel is now indicating correctly.

Link to comment
Share on other sites

2 hours ago, Dr4Film said:

Use the thermostat to turn off the AC not the circuit breaker.

Thanks, Richard, but that doesn't work. The fan would stop, but not the compressor. That's why I suspect a stuck relay on the A/C control board. Since I suspect it is not good for the compressor to run without the fan, I resort to tripping the breaker. When we want to run the A/C I turn the circuit breaker back on (which starts the compressor) and then use the thermostat to turn on the fan.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...