Jump to content

No Low Beam Headlights


Garry Donohue
 Share

Recommended Posts

I have high beams,parking lights, but no low beams. I replaced the hamsar DRL relay and the headlight switch but still no lights. I printed the SM211 Smart Wheel testing directions.All tested good. I'm suspecting the Circuit board that the DRL module is plugged into? Or possibly a connection in the steering wheel column? Tested both light bulbs both ok. Any suggestions?

Link to comment
Share on other sites

Let me check.  They could also be auto resettable circuit breakers.

My hunch was correct it is an auto reset circuit breaker on pcb#8 in the center of the FRB relay is next to it.  See top portion of the attached schematic.

 

Screenshot_20220118-221848.png

Link to comment
Share on other sites

When you look at the circuit board you will see LED indicator lights telling you if power is getting through the circuit breaker and whether or not power is getting through the lo beam relay.  There is the same set of LED indicator lights that would light up for the high beams because you know that the high beams are working.  Should be an easy visual indication of whether you have a bad relay or bad circuit breaker.

Link to comment
Share on other sites

I have a 2007 Dynasty Squire floor plan, 

1 hour ago, ktloah said:

Gary, you never mentioned what year coach you have. My 04 Dynasty had same problem. Connector where it plugs into smart wheel controller was burnt out...replaced with local parts, ( electronic store ) and works fine.

I have a 2007 Dynasty Swuire floor plan. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...