Jump to content

Unknown Fault on Magnum Remote


Recommended Posts

Motorhome is a 2009 Monaco Camelot 42 PDQ.

The remote on the wall is showing unknown fault. It appears there is no power to the charger/inverter. The progressive surge protector shows good power coming in from plug. The remote reads shore power then switches to read gen set when the generator is turned on so I believe the transfer switch is good. Batteries read 12.29 -12.31 but are dropping, the remote does show charging when the engine is running.

Is there a reset button on the charger somewhere? Holding the power button for a few seconds has not worked.

Thanks for any help.

Link to comment
Share on other sites

I had a very similar problem a while back. If you search for “power load balance” lots of good information in there. To do a soft reset there is a little black button on the Magnum charger next to the little green light. You have to push it in for 15-20 seconds and I think it starts rapidly flashing then release.  

Link to comment
Share on other sites

I got the same.  What I would do and what I continue to do.

Check the Magnum.  There are 3 circuit breakers there….small pins.  I would PUSH them all in.  These are not “on/off style, so I don’t pull them out.  It is difficult sometimes to see the differences….but when you push them in….and hold “tightly” for a second or so, that resets them.

Then check the 30 Amp breaker on the main 120 - 50 Amp panel in the bathroom.  Magnum recommends NO POWER ON a for the Soft Reset, although MOST of us, with experience, leave the AC ON.  TIURN OFF the 30 amp breaker.  This is the easiest point to do so.

ASSUMING you have some charge in your batteries, then HOLD IN a the power button in the lower right corner.  You need to hold it in for say 20 seconds.  When you see “flashing” lights, then hold it for a few seconds…..Then release.  Typically WAIT for a few minutes before you turn it back on. So….push it ONCE and release.  That powers it back on.

NOW go inside.  Look at the remote.  You might have to push the meter button,  there should be two green lights…..since you have NO an incoming AC, the CHG light will be off.  It should say “inverting”….and display a DC voltage and Amps.  

NOW…..turn back on the 30 Amp Breaker…go to the remote and make sure the CHG light is ON.  Since you had a fault….maybe from a “low battery cut off”, then make sure the Magnum is set up properly.

Push Shore.  Should be at 30 A….that is your BREAKER rating…. Keep at 30.  Being on a 50 amp service does NOT change how the breaker is rated.  Only change this when you go to a lower service like a 15 or 20 amp household receptacle.

SETUP. These are not necessarily in order…..from my memory. If you do not know how to use the push button rotary knob, find your manual.  This assumes you have the original remote.  They fail.  I have a newer one and the screens are different.  Write these down….as they will need to be checked from time to time.  If the remote is getting flaky, then it has a twisted mind of its own and will change the settings or not allow you to set them.  That is the sign of a bad remote,

Press SETUP.  Search Watts should be OFF…probably reading 5 watts….turn dial to OFF and push the knob….that locks in the setting.  Turn knob to right…

Low Battery Cutoff.  I set mine to 11.9   Magnum has it way too low

Battery….type is FLOODED (assuming you do not Lithium or AGM).  Amp hours is 400….I thing the next setting is 1000….you have two series connected batteries…..usually 220 - 225 AH…so two of them is 450.

Low AC….set it to max, 100….

the rest is pretty simple….the power save and contrast are screen issues.

IF YIU CANNOT set something or the screen is frozen…..bad remote.

IF you still have a fault light…..then Google Hard Magnum RESET.  Follow the instructions…..but leave the batteries disconnected for an hour,

Report back.  If STILL issues, there are several steps to take to isolate the issue.  Not hard.  Don’t need a VOM.  But detailing them here is overkill.  This should fix it…




Link to comment
Share on other sites

Tom Cherry thanks for the info, I did the soft reset. The unknown fault has now changed to Internal Bridge so, now I have disconnected the battery cable and and will wait a while to plug it back in. Hope that resets if not I will call Magnum.

Link to comment
Share on other sites

1 hour ago, JBMB1212 said:

Tom Cherry thanks for the info, I did the soft reset. The unknown fault has now changed to Internal Bridge so, now I have disconnected the battery cable and and will wait a while to plug it back in. Hope that resets if not I will call Magnum.

OK…from the Magnum manual….below,  STOP before your reconnect.  Disconnect the Battery Temp Sensor and the Network Cable.   Or stated another way, pull the two phone cables….leave the REMOTE a cable or phone line hooked up.  Let it sit for an another 30 minutes.  You are bleeding off any stored energy on the printed circuit board…..and that is where the Internal Bridge Fault is happening.  If you had a blip…..sometimes it takes awhile to chase out the demons,

Then, reconnect the batteries…..and look at the remote…..then power (30 amp) breaker on.  This has worked before,,,,,but not seen the dreaded IBF code….

If NO JOY…call Magnum.  My comment…..if you can unhook wires from terminals using a socket or a screwdriver, then you would be better off to order a NEW MS2012….and replace the whole blinkin’ thing.  The board is well over $500…maybe more and you still have a bunch or stuff that could go wrong,  by the time you paid an authorized Magnum shop, you have more than 50%….or maybe 75% in a rebuilt 2009 box.  I would buy a new one and also a NEW a remote (mine failed…..but the Inverter was OK) and do it yourself.

Just some unsolicited advice.  We have had many “not an electronic tech” members pop in a new inverter…..

Good luck…

Perform a hard reset of the inverter. If the internal fault remains or returns, the inverter will require repair at an authorized service center.

Link to comment
Share on other sites

FIRST THING....to be sure....you DID remove the Network and the Battery Temp Sensor phone lines prior to doing the Hare Reset.....if so....then do it....and if the fault stays....

BUMMER....  Another individual just PM'ed me.  He is getting a new Inverter and also got the new Remote.  If you budget can stand that...maybe $175 or so (Amazon), I would advise it.  The remotes will fail....not a major problem, but IF they do, they will mess with the Inverter's settings and your batteries are at risk of damage (over or under charging).  It is SO MUCH better and it takes into account and lets you use all the revisions and features of the updated OS in the Inveterter.

Here is the settings for the NEW RC remote.  Need to get Frank to post them....

TGC Rev 1 ME-RC Setup Guidelines DRAFT.pdf

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...