Jump to content

No Low Beam Only High Beam


Recommended Posts

My headlights are stuck on high beam and low beams are not on at all. Fuses and relays in electric bay on drivers side all check good and have been swapped out. I can hear relay inside dash click when I press the high low beam on smart wheel. High beams flash when the Flash button on smart wheel is pressed. All the other functions on smart wheel are working. I removed all power and restored and same results. Could it be the manual switch on the dash? Good ideas appreciated.

2007 Diplomat 40SKQ

Thanks,

Kenneth

Link to comment
Share on other sites

I don’t know if my 05 sig castle is the same but I have been having trouble with the low beam staying on. My high beam switches on and off with column lever but low beam light go out and will not come back on. There are wires coming to smart wheel controller in side electrical bay and one of them was scorched. They are labeled high and low beams. I replace smart wheel controller, light switch and still had trouble. Turns out wiggling wiring harness from panel going through to front of coach was a loose connection. Cleaned all grounds and connection worked for me.

paul

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...