Jump to content

Brake Lights Intermittent


Recommended Posts

Noticed last week, after not moving coach for months, coach break lights are not working properly. I start the coach. Let it air up fully. Check turn signals (which work fine). Pump brakes. Side brake lights, and the center brake light strip, all work on the first pump of the brakes. Then either nothing or intermittent. Shutdown engine, wait, start engine, same problem. Thought maybe the reply. Replaced. Did not resolve. Someone suggested the switch by the pedal? Not sure. Would appreciate help. Monaco Knight 2005. 107k miles. Thank you. Fred

Link to comment
Share on other sites

There should be a air operated switch on the firewall (open generator slide) that supplies a ground when you put on the brakes. Shorting across that switch should turn on the brake lights every time.

Link to comment
Share on other sites

  • 2 weeks later...

I'm still in need of advice regarding this problem. I thought I had a repair tech who could do it, but yesterday he decided it was beyond his expertise. Again, the rear brake lights will not come on when applying the brakes. When I air up the coach, and first hit the brake pedal, the lights come on. Once. Then that's it. Never again until I turn off then back on. Again, I get one flash of the brake lights, then nothing after the first flash. Thank you

Link to comment
Share on other sites

  • 11 months later...

Any updates on this issue?  I'm interested in the solution if you've found one for this issue.  I'm having the same issue, no break lights working.  They worked fine before winterizing and storage last year.  Turn signals, rear drive lights and emergency blinkers work. I checked bulbs, fuses and all Relay that were labeled for Brakes or ABS in the schematics I have, no luck.  I even replaced the brake switch on the brake the pedal.  Brakes work fine.  They are hydraulic not air.  This is a 08 LaPalma XL Diesel 34 PDD.  I have the Monaco CD with all the schematics for this motorhome.  Any help, ideas or solutions are greatly appreciated.  Wondering if the Brake booster could be the issue?  I don't know what that would feel like if it was the issue as the brakes feel fine to me.   I know the Monaco motorhomes can sometimes be different within the same models.  I can post pictures of the booster, schematics etc. if that help.  I noticed there wasn't much of this in the Files section.   

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...