Jump to content

Trimark Keypad


Timmy C.
 Share

Recommended Posts

I have 2006 Monaco Windsor, tried to lock the door and bay doors with the keypad but they will not lock. Used the key fob and it will lock and unlock both entry door and bay doors just fine. The keypad will also unlock both sets of doors as it should. The keypad beeps when the keys are pushed and sounds like it always has. I'm at a loss on this one, any ideas?

 

Link to comment
Share on other sites

1 hour ago, Timmy C. said:

I have 2006 Monaco Windsor, tried to lock the door and bay doors with the keypad but they will not lock. Used the key fob and it will lock and unlock both entry door and bay doors just fine. The keypad will also unlock both sets of doors as it should. The keypad beeps when the keys are pushed and sounds like it always has. I'm at a loss on this one, any ideas?

 

Chuck is our Windsor guy.  But if you have the Trimark and not the Essex, I would call Trimark and talk to them.  There is a diagnostic and such that might clear the issue.  Memory says that Trimark said to go into the “setup” or configure mode….then back out.  No changes.  They also have a good manual.  Just verify you have the Trimark system first,  let us know what they say and what you find out.

Thanks.

Link to comment
Share on other sites

The Essex KE 1700 series keypad requires two actions to operate the keypad when the button is pushed.  The first action is the pressure on the button to make contact and the second action is the heat from the finger pushing the button.  After years of use the button does not release when pushed.  The sun shinning on the keypad provides the heat.  Then the two conditions are met.  That is why the keypad will operate opening and closures at random times.  That is why I recommend replacing the keypad.  

Link to comment
Share on other sites

I push #1button to lock the rig and storage doors. If I don't hear a click indicating lock Clean the contacts on the inside hinge side of the door jamb with an eraser, oooo steel woll or very fine sandpaper. Happens about once a year.

Tom Westerfield 

2006 windsor

Link to comment
Share on other sites

Occasionally my TriMark goes out of sync. This happens a couple of times a year. The fix for me is to wait until the system settles and then  enter the full 4 digit UNLOCK code. I usually don't get a response but then when I hit the old 555 I get the satisfying sound of locks engaging all around the coach. 

Usually to unlock all I hit the first 3 numbers and then the number "9". I don't know what causes the sync issue.

Good luck

Ken

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...