Jump to content

See Level tank sensors not working


StephenW
 Share

Recommended Posts

After installing the See Level tank monitoring system in my 2001 Dynasty I noticed the black and grey water tanks registered 0% on both.  The fresh water, batteries and propane all worked properly.  After going through the troubleshooting guide it looked like the tank wall thickness was too thick.  I thought maybe the wall of the tanks were coated with crud.  While reading a post about tank sensor issues I read Tom Cherry's post about using "Happy Campers" to keep the tanks clean. Ordered the Happy Campers product and dosed my tanks prior to leaving for Eastern Oregon.  Tank sensors are now working properly!

THANK YOU  Tom Cherry

I will now use Happy Campers product regularly.  Thanks again to this forum and all who provide so much great info.

Link to comment
Share on other sites

2 hours ago, StephenW said:

After installing the See Level tank monitoring system in my 2001 Dynasty I noticed the black and grey water tanks registered 0% on both.  The fresh water, batteries and propane all worked properly.  After going through the troubleshooting guide it looked like the tank wall thickness was too thick.  I thought maybe the wall of the tanks were coated with crud.  While reading a post about tank sensor issues I read Tom Cherry's post about using "Happy Campers" to keep the tanks clean. Ordered the Happy Campers product and dosed my tanks prior to leaving for Eastern Oregon.  Tank sensors are now working properly!

THANK YOU  Tom Cherry

I will now use Happy Campers product regularly.  Thanks again to this forum and all who provide so much great info.

Glad it worked.  A buddy put them in his Caamlot….myabe had 6 months of full time usage.  He had to clean the tanks twice.  That was in the trouble shooting guide and See Level said specifically to use some type of “chemical” and NOT the septic tank yeast stuff.  You may have to clean every six months….but drive on and see.  I would also not recommend totally draining and flushing….leave a little liquid….like the Happy Camper instructions say.  Mine are still ugly, but better…

Tanks for the compliment…..

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...