Jump to content

Kwikee Steps Problem


Recommended Posts

My Kwikee single step continues to run for 5-10 seconds when opening or closing the door.  They do not lock in place unless I pull on them.  When they retract they continue to run for a brief period and I must push them in.  They often will not lock into a fixed position.  Should I remove the steps and clean them thoroughly or is there a limit switch problem or ??

Gary B. 

2002 Monaco Windsor PBDD

Link to comment
Share on other sites

More than likely you have a missing  tooth on the gear.  They break off from getting in a bind or stepping on the steps before they are fully extended.  I had the same issue on my rv.  Found the gear online and replaced myself.

Edited by Bootlegger
Link to comment
Share on other sites

Sounds like internal motor issue, could be the plastic gear which is replaceable for about 20 bucks or in the case of the step motor on my 07 Knight the metal piece that drives the gear on the outside of the motor got stripped. Fixed it with JB weld untill new motor arrives.

 

Link to comment
Share on other sites

Just replaced the step motor and controller on our 2001 Holiday Rambler. It was doing the same thing your is doing. I took it apart and found some corrosion in the motor. Decided to order the replacement kit for mine because certain parts weren't available any longer. The new parts were very easy to install and were plug and play. If you call kwikee they will give you all of the info you would need to repair or replace yours.    

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...