Jump to content

Generator Slide switches not operating

Recommended Posts

Hello All!  I have a 2005 Windsor that the generator slide will not move with the switches.  I was able to jump the solenoid main terminals at the pump to move it out and in to complete an oil change on the generator.  The switch in the front run bay has 12 volt power to it, and works correctly (12 volt out on each leg when the switch is pressed each way).  I did not have time to disassemble the switch next to the driver seat.  Is the wiring diagrams show a controller and lock out relay for the generator slide, but I have not found a controller, and it should be a very simple configuration that does not require a controller board.  Anyone know if there is an actual generator slide controller? or how the two buttons are wired?  could be parallel (the FRB switch is single pole double throw), but have not looked at the driver seat switch.  I tried applying 12v to one of the solenoid control terminals with no luck - I was by myself and did not think to run a long enough jumper to attach a meter where I could see if it got 12 v when I pressed the switch.  But I didn't think both solenoids would fail at exactly the same time....    Any suggestions for troubleshooting?  anyone know if there are other relays or a control board in the circuit? 

Thanks, Dennis Nelson - 2005 Windsor - with 2011 Lincoln MKX toad.


Link to comment
Share on other sites

4 hours ago, David White said:

Dennis, have you tried the switch in the left front electrical bay?  

Yes, the switch in the front run bay (outside below driver window) has power and appears to work correctly when checked with a multi meter.  Have not disassembled the console next to the driver's seat yet to determine if that switch is working properly. If they are wired in parallel, it should not prevent the front run bay switch from operating the slide.

Link to comment
Share on other sites

  • 2 weeks later...

RESOLUTION: After much disassembling to check switches, which checked out to be working correctly, I pulled the wires off of one solenoid at the pump to check continuity - and the wires had power when switched and the other solenoid worked with the switch!    I got lucky when I disconnected the bad solenoid; I have no idea why one bad solenoid prevented the other from working (maybe some internal short that that tripped the breaker when either was activated?), but glad it was that simple.  Installed a replacement from Amazon and all works well. LESSONS LEARNED:  When troubleshooting - start at the easiest to reach locations - the pump end and remove wires to confirm voltage and ground before digging into the armrest switch!  For anyone with this problem in the future, the original solenoid is marked SAZ-420IER  ASSEMBLED IN MEXICO 12V 4PA 06 AI  .  I purchased a "dump trailer solenoid" from Amazon that replaces SAZ-4201ER and all is working fine.  I spent about 3 hours trouble shooting, the repair with part in hand took less than 15 minutes.  On to the next project!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...