Jump to content

HI-AMP Buss 120A tripped

Go to solution Solved by Tom Cherry,

Recommended Posts

Good Evening,

I was exercising my generator. Turned on the Water Heater and one roof top AC to load it. It ran for a few minutes than shut down. No power to any 12v or to the Gen Start. Found the HI-AMP Buss 120A tripped. Reset it and all is fine on shore power. Have not tried it on the Gen Set. Any ideas what may have caused this?

Link to comment
Share on other sites

Were you connected to shore power while running the generator?  Did you connect to shore power while the generator was running?  My transfer switch does sometimes get confused if both are connected... and trips the breaker.

By "all is fine", do you mean you ran the AC & WH for a while on shore power and the 120A breaker didn't trip? 



Link to comment
Share on other sites

I started the Gen then disconnected the shore power probably a minute or so later. I normally disconnect shore power than start the gen. To answer your question I run my airs and battery charger/inverter all the time at home on shore power while stored. Once a month or so I disconnect the shore power, start the generator, turn on 1 AC and the Water heater to load the gen to around 20 amps and let run for a couple hours. Thats what i was doing when it tripped the HI-Amp Buss. I normally do not start the gen than unplug shore power. Just goofed it. The Gen ran for probably 5 minutes before tripping the Buss which killed the Gen Set. I have not restarted and loaded the Gen as I was unsure of what tripped the HI-AMP buss. I do have the original transfer switch which I have read is unsafe. Will be swapping that out.

Link to comment
Share on other sites

1 hour ago, Olethehammer said:

Good Evening,

I was exercising my generator. Turned on the Water Heater and one roof top AC to load it. It ran for a few minutes than shut down. No power to any 12v or to the Gen Start. Found the HI-AMP Buss 120A tripped. Reset it and all is fine on shore power. Have not tried it on the Gen Set. Any ideas what may have caused this?

Just curious.  Have read and reread the posts.  A little confused.

YES, if you are on Shore and running an AC and leave BOTH circuits live, you WILL have or probably have an issue.  When you start the genny and let it warm up and wait a few minutes, then turn ON the AC, you probably have an elapsed time of 5 minutes.  The Genny should be OK. BUT, if the AC was on and you had both running, then there was NO shutdown of the AC.  When you turn off the AC, there is a countdown timer for 120 seconds….so 3 minutes to let the Genny start to warm up…then add in the next 2….by that time, the Genny is up and running and all is well.  It sometimes takes a 30 minute wait…NO GENNY for the electronics to reset.  YES…I know this for a fact from experience….and I have NEVER done that again.

NOW….here is where I am totally at a loss.  What “exactly” are you referring to as the 120 Amp or Hi-Amp circuit breaker.  I scanned a set of 2006 Diplomat prints but didn’t find it.  The Genny is providing AC power for the high current items like water heater, AC’s, etc.  The Genny does NOT charge or impact the House DC System.  It does provide power for the Inverter/Charger.

Next up, the ATS is VAC or AC power.  There is NO DC input.  The ATS, all of them, will switch from normally closed SHORE to GENNY, when there is INCOMING Voltage or the Genny is running and then the ATS says, HEY, power from the GENNY….I MEASURED IT.  They MUST not have any shore.  I need to switch or close the relay(s) and send the Genny’s AC to the main panel.

NOW, if you have the original IOTA 50-R, then it is our responsibility as Moderators to inform you that it is a dangerous device and needs to be taken out of service and replaced immediately. It is a personal LIFE SAFETY and PROPERTY RISK.  You can search…I don’t think that we have had any major fires here, but many have and destroyed or severely damaged their MH. We have many reports of minor fires and scads of reports of damaged internal components and charred and burned contacts.

The ESCO LPT50BRD is the most used or preferred replacement. There are others.  You can search using IOTA and read.

If you could,be more descriptive or take a picture of the HiAmp Breaker and what it controls….that would be helpful.  But this is a DC item and the Genny is AC and the two circuits are not interconneted…


Link to comment
Share on other sites

Thanks for your reply Tom. Pics attached. I will replace the Transfer Switch asap, a bit flooded right now here in Southwest Florida! I will not fire the Generator until it is replaced to be on the safe side, thanks for the heads up on that. I wasn't very clear on the steps to the failure in the previous description:

I was plugged into 50 amp at my home, I leave the coach plugged in all winter at home. Normlly I would unplug shore power before firing the Generator but failed to do so this time. After firing the Generator I exited the Coach and noticed the Progressive Power Surge protector was still lit. I immediately unplugged the Shore Power with the Gen running. Probably should have killed the Gen than unplugged but didn't. After unplugging the Shore Power the Gen ran for around 2-5 minutes with 1 air and hot water heater on to load the Gen, it ran for around 2-5 minutes before it died. I went back to the coach and all 12v was down including the switch to start the Generator. Found the 120v Buss shown in the pics tripped. It felt like it reset properly. After resetting the Buss I then checked 12v inside the coach and it appears all is good. Cannot get to the Transfer Switch without wading thru a couple inches of water and standing in water while I investigate the Transfer Switch. I will wait for the water to recede.  I run the Gen once a month under load for around 2 hours to excercise. Been doing this for years with this and all previous coaches. I understand the Gen and DC are seperate, that is why I was confused as to what caused the Buss to trip. 


Thanks in advance for your attention!



Monoco DC buss pic 2.jpg

Monoco DC buss pic.jpg

Link to comment
Share on other sites

  • Solution

Thanks for the explanation.  I will surmise this

The Generator was unhappy due to the AC load and not being properly warmed up. It should be FINE.  

Had to download the prints.  Here is what you need.....

It appears that something, NO IDEA WHAT, tripped the Breaker. It is for the HOUSE circuit.  The Genny and the alternator are NOT an issue... That 120 Amp breaker eventually feeds the Front House Solenoid and it has a 50A breaker on it....so do idea on that end.

If you look at the Hight Current Print, which is the rear.

The House Disconnect Switch feeds it.  Then there is a 2Ga cable to a T-Post.  The Jack Motor and Front T Post (where the Solenoid is) and a BUSS in the back. The buss has two Circuits...  NO IDEA what TRIPPED it.  The Generator or Starting cables, elude me....  SO, I can't do much there.

I WILL say that if you have an issue again, I would replace the 120 High Current.  NO IDEA...except something spiked. 

You MIGHT also be in need of new House and Chassis Disconnect Switches. They do have issues.

I had a phantom like this and it repeatedly blew a 200 Amp fuse....and finally found a Hydraulic motor that was drawing WAY too much current.

That's about as much as I know or can speculate 

2004 Ambassador_Knight Wiring (1).pdf 2004 Diplomat and others - High Current Rear Run Bay.pdf 2004 Diplomat and others - Overall High Current Power.pdf

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...