Jump to content

GFI / Magnum


Joel Sheriff
 Share

Recommended Posts

Will a bad GFI blank out the magnum board even if plugged in. I'm in a30amp site with no reading on the magnum no kitty to set AGS no amp readings but batteries seem to be charging 110 electric is ok, running extensions, Inverter is on at source. I tried unplugging the magnum 5 button in back and plugged back in. Nothing. Reset Inverter, nothing.  No Inverter 12v working in coach including fridge. I ran extension to get the essentials, fridge, coffee reclining chairs etc.  Any thoughts beyond GFI.  Oh I checked panel, no breakers off. 

 

 

Link to comment
Share on other sites

If the inverter is supplying power to your 110 volt outlets and charging the batteries, then the Magnum remote panel is likely dead.  Mine went wonky and unplugging and re-plugging the board made it better.  A few months later it died completely and I replaced it.  All is well now.

Here's a link to my panel on Amazon

https://www.amazon.com/Magnum-ME-RC50-Remote-Control-Inverters/dp/B00LCCFZZ0/ref=sr_1_6?crid=3T2U2F13MOKV2&dchild=1&keywords=magnum+me-rc50+remote+panel&qid=1600023547&sprefix=Magnum+ME-RC%2Caps%2C243&sr=8-6

Link to comment
Share on other sites

Have you tried starting the generator?

Is the green LED status light on the side of the inverter (in the basement) off, flashing slow, or flashing fast? 

Have you checked the three small round white push in circuit breakers on the side of the inverter?

Next thing to try is an inverter reset by depressing the white inverter power button (on the side of the inverter next to the phone cord) for 15 seconds until the LED comes on and starts flashing rapidly.   

Link to your inverter manual:

https://www.magnum-dimensions.com/me-series-invertercharger-owners-manual-64-0002-rev-c

Edited by vito.a
Link to comment
Share on other sites

Joel:

I can't imagine that the GFI and Magnum display not working are related.  The magnum display is on a low voltage circuit not connected to the GFI in any way that I can imagine.

If the two things happened simultaneously, that is odd indeed and I don't know what to make of it.

In your original post you said: "No Inverter 12v working in coach including fridge".  I don't believe that the inverter supplies 12 volts.  Do your ceiling lights work?  If so, you've probably got 12 volts.

Do you have an MSW inverter?  If so, not every GFI is going to work on inverter.  Don't ask me how I know . . .

If you have an MSW inverter most any GFI will work while you're plugged into shore power.  When you unplug and go on the inverter, some GFIs will trip.

If I were you I'd pick up a GFI at Home Depot, Lowes or any hardware store and replace the defective one.  I think you'll find it will work on shore power.  If you have an MSW inverter, I'd then call Magnum and ask them for a list of GFIs that will work with MSW. Xantrex has a list that I posted in response to another message thread.  I used the Xantrex list to eventually find a GFI that works on MSW.

Based on my experience, I'm pretty sure that you need a new Magnum control panel.

Dwight

 

Link to comment
Share on other sites

Dwight, I agree on the magnum remote being bad. I'm calling about it tomorrow of course it happens on a weekend.  As for the GFI, I am going to home depot tomorrow to switch out either way  it's not resetting and I agree it should be getting power from the Inverter. As for kitchen lights and duplex outlets near bed, they work from shore power. My fridge, residential, was originally installed to work off the Inverter which is a msw 1200 series.  Fridge should have read not working off Inverter had to run an extension from bedroom to back of fridge to power.  Micro, TV, most outlets not working but fluorescent lighting is working. Galley totally out. I'm changing out both items... GFI and magnum remote. I'll keep the forum posted. Thx for the input. 

Link to comment
Share on other sites

I believe to do a reset of the inverter you need to disconnect the 110 and disconnect the batteries. When the inverter turns on it should say set clock. I take it you do not have the instructions for it. Fluorescent does not work off inverter. My bedroom GFI works on the inverter but trips on the generator, go figure. Since the inverter has a pass through when on shore power and if your bedroom works then your fridge should be working off shore also. That is the transfer switch inside the inverter. Make sure you switch breakers off then on to reset them. Like I said if the bedroom has power then the fridge should too. I would try a battery disconnect reset. The plugs have a test and reset button and there is also a GFI in the power panel box. I have one in the inverter box and in the main power box.

Link to comment
Share on other sites

Tim, I didn't do a hard reset on the Inverter just an off, sit, and back on. My GFI works of the Inverter but the inverter is working so it has to be a coincidence that both the magnum remote and GFI went together. I'm replacing both. My fridge, when installed after my Norco had an Inverter plug behind and that's the plug they used when installing my fridge. My GFI is in the bathroom and controls all my duplex plugs except my bedroom night table  plugs. They are 110 shore power or gen. When no shore power I plug my Bipap and clocks into the bathroom GFI when no shore power. Fridge continues to work off Inverter and batteries when traveling. When you say switch brakers are off then reset do you mean at my panel breaker box or on the Inverter? There are no tripped brakers on my Inverter. And my breaker for the Inverter seems to be good although I have not yet checked power coming off the breaker. 

Link to comment
Share on other sites

To followup on this, I unplugged from shore power and all the outlets were dead. Replaced GFI and found a bad connection on the Inverter side of the telephone communication wire between the remote and the Inverter. Fixed the wire connector and the remote works, didn't have to replace it. New GFI and my plugs on the galley side of the coach work  micro, duplex plugs, bar area but on my opposite side, curb side plugs don't work. Nor does the directv or box power up as well or on wall on vanity opposite the GFI in the commode closet.  No popped brakers and no other gfi's I can find on the coach... What's next why are these plugs not working now can I have a faulty new GFI?? Or something else popped off somewhere? 

Edited by Joel Sheriff
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...