Jump to content

Not auto leveling with a Valid air system


Margie
 Share

Recommended Posts

We have a 2007 Camelot 40ft and cannot get the auto leveling to work. We have the Valid air leveling system. Parked at campground and the coach is staying in ride height.  Looking for leads to check what is causing our problem.  Thanks

Link to comment
Share on other sites

On 2/16/2021 at 12:32 PM, Paul A. said:

Hold the POWER button down a bit. It may re-boot.

Could not get it to reboot. We also removed the panel and checked the connections which look good.  Checked  all the fuses and found nothing. 

On 2/18/2021 at 6:03 PM, 96 EVO said:

Will it go into manual mode? If so, it could be your parking brake switch.

Also, the Valid control panels fail frequently.

Does not go into manual 

On 2/16/2021 at 9:46 AM, Hypoxia said:

Thank you for the manual 

Link to comment
Share on other sites

  • 3 weeks later...
On 2/18/2021 at 6:03 PM, 96 EVO said:

Will it go into manual mode? If so, it could be your parking brake switch.

Also, the Valid control panels fail frequently.

 Thanks, but it doesn't go into manual 

Link to comment
Share on other sites

  • 2 months later...
On 3/7/2021 at 9:28 PM, Barryc737 said:

Are you pretty level to begin with?  If you're "out of limits",  you might be locked out of AUTO so as not to twist the frame.

Is there a way to "unlock" AUTO if that were the case? 

Link to comment
Share on other sites

Barry--

Thanks for the response, but since none of the other buttons, including "Manual," on control pad are operational, that won't work.  Unit appears to reset by holding the Power button--power light flashes and pad beeps--but none of the other buttons appear to work.

I am leaning toward a bad control panel at this point, but was putting out a Hail Mary for last minute input...

 

Link to comment
Share on other sites

I agree with Ben their canned answer is it got wet.  Mine have never gotten wet that I am aware of, but a new control panel has fixed me up several times in the 13 years that I have had our coach, if the reset and checking the connection to the panel hasn't fixed it.

Link to comment
Share on other sites

Mine intermittingly failed to operate in Auto.  I found that switching the ignition around it would start to work.  Now only Manual works.  I had never seen a Operating/Service  Manual before and was not aware of the holding of the power switch for reset.  My question is if I do that and it works, do I now have to recalibrate everything.   Or does the memory hold?

Thanks

Link to comment
Share on other sites

1 hour ago, Rich Cutler said:

Mine intermittingly failed to operate in Auto.  I found that switching the ignition around it would start to work.  Now only Manual works.  I had never seen a Operating/Service  Manual before and was not aware of the holding of the power switch for reset.  My question is if I do that and it works, do I now have to recalibrate everything.   Or does the memory hold?

Thanks

You should be fine.

Like I mentioned, mine is failing. The only way I can power it down is hold the power button for the 10sec till it beeps. Done this many times now, and never had to recalibrate anything.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...