Jump to content

Recommended Posts

2 hours ago, Dr4Film said:

What are you leaking? With more information you would get more possibilities.

Oil leak. I put that in the tags.

Link to comment
Share on other sites

1 hour ago, TOBYLB4 said:

Oil leak. I put that in the tags.

OK Oil leak. What tags are you referring to as your post mentions nothing about an oil leak that I can see. What am I missing?

As Vito.a stated, valve cover gasket would be what I would look for first. Then once that has been eliminated start looking elsewhere.

 

4 hours ago, TOBYLB4 said:

Leak appears to be coming from the head above the ECM. Anyone else run into this? Hoping it's the head gasket. Any help appreciated.

 

Edited by Dr4Film
Link to comment
Share on other sites

If you look under my heading "07 Dynasty ISL 400 you will see oil leak. And no it's not the valve cover. That's  what you're missing.

Link to comment
Share on other sites

28 minutes ago, TOBYLB4 said:

If you look under my heading "07 Dynasty ISL 400 you will see oil leak. And no it's not the valve cover. That's  what you're missing.

Gary, thanks for pointing that out. On my screen that "Tag" is so light and small that I had to get closer to the laptop screen just to read it. That's how I missed it completely. If it was in a bigger font and in dark bold letters I would have seen it for sure.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...