Jump to content

ScanGauge D not working on engine/transmission diagnostic port


Recommended Posts

I’ve had my ScanGauge D for a couple years plugged into the diagnostic port by drivers left knee, but last trip it was not working. Display was blank. I also tried plugging into the engine bay diagnostic port. Engine and transmission data is available via the Aladdin system.

I called ScanGauge and described my problem. They had me send it in to have it checked out. They found no issue, but sent a different unit back, which also doesn’t work.

Has anyone else had the same issue?

Paul

Link to comment
Share on other sites

Mine works fine. I have it on Auto-ON which turns it on when the voltage changes and sometimes with solar charger working it does not register and remains blank until I push whatever button. Doubt that would be your problem however.

Link to comment
Share on other sites

On my 04 navigator I would lose connection on my blue fire plugged into the diagnostic port but the Aladdin would also shut off at the same time. Found a broken ground going from the diagnostic plug in the engine bay to the starter.

You could try plugging into the port in the engine bay. If it still doesn't work I would test the ports. You can look this procedure up on line. 

Link to comment
Share on other sites

Mine works fine. I have it on Auto-ON which turns it on when the voltage changes and sometimes with solar charger working it does not register and remains blank until I push whatever button. Doubt that would be your problem however.

My chart shows Diagnostics power fuse (1 amp) in chassis fuse section in FRB. I don't know if it is actually used and I never had to trace it but might be worth a look. It is a different fuse from ABS diagnostics so it might...

Link to comment
Share on other sites

Thanks for the pointer @Ivan K I checked the 1A fused marked DGN PWR and found it was blown.  I replaced it and the ScanGauge D started working again.

Thanks also to ScanGauge who provided unquestioning support for a product that was nearing the end of a long warranty period.

One piece of data I would really like to display on this is the transmission gear selected. It is available on the Aladdin, and is not a standard field on the ScanGauge D, so I will scan the PID data again and check with ScanGauge to see if it is available as a X-Gauge.

Paul

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...