Jump to content

Front AQUAHOT (Furnace) Zone Not Working After HVAC Upgrade - 2007 Camelot

Go to solution Solved by bandmmorris,

Recommended Posts

I have a 2007 Monaco Camelot 42PDQ. Last year the front AC (zone 1) quit and I replaced it with a Dometic Penguin 2. To get the Penguin 2 to communicate with my CCC 5 button thermostat I installed a Power Module Board Conversion Kit. The only "on" dip switch on the board is for the furnace. I have spoken with Dometic and confirmed I have the correct conversion kit for the AC I have. After installing the AC and conversion kit all of the zones and all of the thermostat settings work with the exception that the furnace setting on Zone 1 does not work (It was working on the old unit before the AC quit. The furnace setting on zone 3 (rear) works.  As a result I cannot get the front furnaces to operate. Any suggestions will be greatly appreciated. I have had several calls with Dometic with no success on this problem.

Link to comment
Share on other sites

I'd first try a thermostat reset.  Turn the thermostat off (small black button on the underside).  Hold down both the top and bottom buttons while switching the thermostat on.  You will see FF in the display.  

Then see if the zone 1 furnace shows up.  

If this doesn't restore it, then you have either a bad connection in the RJ11 cord, or the control board dip switches are not set correctly.  I'm guessing the latter as there should be several dip switches set to duplicate the original control board.  

Link to comment
Share on other sites

I can only tell you this.  When the thermostat or a remote sensor calls for a furnace, the control module must send a 12 VDC signal to the AH control board.  If you measure the voltage it should be there.  We had another member with a weird situation.  

Measure the voltage on the Zone 1 thermostat wires. Mark them before you pull them.  The wires are smaller….#14.  The wires going to the front fans or registers are bigger…# 12.  Put the Thermostat into FURNACE - Zone 1 (front).  Then set it so it is calling for heat.  THEN measure the Voltage at the AquaHot control board.

I included my print.  Yours system MAY be different, so look at your prints for which zones are provide heat to which sections of the MH.

EDIT....your system may be different.....there were some running changes.  If you have the "Furnace" (under the refrigerator?) than us the other print labeled 2007 Camelot.  Either way, the Dometic HVAC control should be sending a 12 VDC signal (assumed based on past trouble shooting) to the AquaHot control board.  

You can also do a “swap”.  Look on your prints or the ones I provided for 2009.  Whichever one matches your layout or "Furnace Configuration", use that..  

If you look at the AquaHot and Thermostats, that is for the 2009.  Pay attention to which zones (on the AquaHot Board) goes where.  In the 2009, the Aquahot board shows Zone 5….as being controlled from the Zone 1 thermostat.  There are two sets of wires….incoming Thermostat and outgoing fan voltage..  your zone 3 bedroom controls the AquaHot zone 1.  So  reverse the wires (turn off the thermostat) on Zones 1 and 5.  Now try it.  If the front comes on when the rear bedroom is calling for heat, you know that the AquaHot controller of board works.  If the bedroom comes on when you reverse and the front thermostat is calling for heat, then you know the HVAC control board is working and you have a good signal, but if the rear doesn’t work, you are not getting a good signal.

I SUPPOSE you have cleaned the contacts on the front system.  I also SUPPOSE you got NEW inline phone connectors.  Then I also SUPPOSE you have reset the thermostat so that the Control Module is in full communication with the Thermostat.  

BTW.  The “furnace” dip is the only switch that should be "ON" as the system assumes it is “Zone 1” when you do not turn on any of the other dip switches.

Hope this helps….


Aquahot and thermostats.pdf AquaHot Diagram - 2007 Camelot & Scpeter.pdf

Link to comment
Share on other sites

  • Tom Cherry changed the title to Front AQUAHOT (Furnace) Zone Not Working After HVAC Upgrade - 2007 Camelot
  • Solution

Thanks for all the comments. They were all helpful in troubleshooting the problem. I have fixed the problem. The issue that caused me problems was that when I installed the new AC and conversion board so I could use my 5 button thermostat there were 2 blue wires coming from the AC board. Inside in my AC area there were also 2 blue wires which I connected them to. Seemed reasonable, but not correct. There was also a green and a brown wire that I did not use. It turns out the blue interior wires are not needed (I think they may have been for a furnace and not an AquaHot). The brown and green wires were actually the wires to the AquaHot. When I connected the blue wires from the AC board to the green and brown wires everything worked as it should. Once again, thanks for all the comments. This site is amazing as it seems there is hardly any problem that someone out there does not have a solution for.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...