Jump to content

Windshield wiper motor


Recommended Posts

 So yesterday as I was coming into Reno my windshield wiper started messing up.  I’m wondering if the motor might be going out it’ll go up a little bit and then stops and it doesn’t wanna go back down to the park position. I was wondering if anybody knew the part number Are had any suggestions thanks.

Don

Link to comment
Share on other sites

Have you looked in the parts list?   You should down load the list if you haven't already done so.    In case you don't know about it,  look near the top of this page and find downloads,    that will take you to all kinds of good stuff along with the parts list that Frank McElroy has so graciously organized and maintained for dummies like me

Link to comment
Share on other sites

I had a similar problem on my Vacationer, may possibly be the cause of your troubles too.  Took a look at the linkage and found that it was rusted.  Sprayed liberally with WD40 and it solved the problem. Then sprayed with lithium to prevent further rust problems.

Link to comment
Share on other sites

Also had the problem...arm would move slowly then stop.  Toggling switch would get it back to parked position.  Assuming motor's overload protection would kick in.  After changing out the motor and lubing linkage found that the pass side arm shaft was binding.  Released some of the tension on circular spring lock and relubed.  So far, so good.

Adam 2010 Neptune 37PBQ

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...