Jump to content

Slides not working; 2005 Cheetah

Recommended Posts

I am guessing this is a fuse issue but just in case..... I ran today over to where our 2005 Safari Cheetah is stored to quickly get it ready for a hard freeze. Here is the gulf coast area we generally do not winterize as the possibility of temps below 30 for more than a day are rare. Tonight, we're expecting high 20s for about 6 hours and then a warm up followed by an arctic blast in the high teens or twenties that will last about 48 hours. For that I drain all the water from the system using the low point drains below the wet bay, pull the plug in the water heater, remove the filters, softener and water pressure gauge, etc.

While at the RV I took the time to exercise the generator and engine and put some charge on the chassis batteries. The house batteries are LFP at 70% SOC

While doing all this I went to operate the slides (3) and none worked. There was no noise, no reaction at the 12v lights, nothing. All indications are no power to the motor. What was perplexing was that all three slides had the same reaction, nada. I am pretty sure these are on on separate fuses and it is strange that they would all go bad at the same time. Likewise I find it doubtful all three grounds on all three would go bad at the same time. All slides worked fine in November when we returned home. Any suggestions on what else I should be looking at?

Link to comment
Share on other sites

I had a similar issue with two slides. Did a lot of reading. Found 3 possible causes for multi.slide failure.

1) ignition on. Slides won't work if it thinks the ignition is on.

2) some models have a bay door interlock that prevents slides from working if the bay door isn't closed. Not sure if you have this. I didn't.

3) Electric slides have a common controller. The controller has a resettable circuit breaker on the control board. My issue was that the connection was bad. I replaced the breaker with aone from NAPA and it worked fine for several months, then I gently tightened the female spade recepicals that held the resettable circuit breaker and it fixed it. You would need to look at your owners manual and find where they put the controller. Mine was UNDER the floor of the cabinet that held the washer. Not fun to remove but otherwise easy to fix. It also seemed to be temp dependant, didn't like to work in cold i.e. would work after travel, when the cabinet was hot from the engine but not in the morning when it was cold when we needed to leave.

Good luck.


Link to comment
Share on other sites

First UP....  We do NOT specifically have prints that were dedicated or provided for the 2005...but here is one that lists MOST of the models impacted and the Cheetah is on of them....

OK....there appears to be some options....as usual. The first print (slide control) appears to be the STANDARD system. It uses a DIODE (CHEAP) logic that Monaco was famous for. There are ONE Fuse and ONE Circuit Breaker.  Check them first.

IF you have this panel, then there is a RELAY 1 Ignition LOCKOUT.  Look on the Front Run Drawing, it is the relay at the top RIGHT (R1) that is in the schematic. AGAIN, as stated in a previous post...if that Relay is bad or the Ignition signal is not there, then they ain't gonna work.

Look, again, at the SLIDE print and the connector. You MUST have 12 VDC power on pin 10. USE your VOM and verify that you have power.  IF NOT, then look at the 50 Amp Breaker in the lower left of the Front Run print.

That's about it.

YES, these drawing are NOT the easiest to follow, but it is all Monaco provided.

There is only two conditions that must be MET...  Voltage (5Amp Fuse & 25 Amp CB) and POWER to Pin 10.  The second is the Relay signal or "switch in the lower portion.

Good Luck....let us know...


DOWNLOAD this file for your records.

LOOK and STUDY the prints below.

IF you have the optional (and that was NOT clear...maybe the E-Sync) rear slides, there are separate drawings. If you look at the various FUSE DISTRIBUTION PANELS, there are separate fuses for the CURB and ROAD REAR Slides...  That is a bit ambiguous....but FWIW, it is there...

Odds are...  You have, hopefully, the front.

FWIW, if you are not familiar with the DIODES and Monaco's funky Control Circuits. The Diodes in the picture for each switch allows just ONE power lead for all the switches and then the Diodes allow power to go FORWARD (the direction of the arrow). My Camelot is like that and it works and is very robust.

SO, power needs to go to the switches (the 5 amp fuse) and then power (25 A CB) to the motors....which are controlled by Relays. I do NOT know if these are standard Bosch plug and unplug relays on the board...but there are THREE of them.  For all THREE NOT to work....a common cause...

And I covered that earlier...

SLIDE CONTROL 2005 LaPalma_Knight_Cheetah_MANY OTHERS.pdf 2005 LaPalma FRONT RUN Wiring Diagrams.pdf

Link to comment
Share on other sites

19 hours ago, Ivan K said:

Was it while engine running? If so, that would likely explain it.

Not 100% sure but that is likely. As I just wrote to John, if that proves to be the case it is another lesson on avoiding multi-tasking with your RV.

Link to comment
Share on other sites

  • Tom Cherry changed the title to Slides not working; 2005 Cheetah

I'm in the same boat with winterizing in the past 2 days. We will be in the teens here near New Orleans for two consecutive days.

I had the same issue with my 2004 4 slide Cheetah. 

If it is not your ignition being on then check the following:

1. My slide relay control board was in my inverter bay up in the ceiling under a black plastic cover. There is a circuit breaker and a blade fuse. My blade fuse was blown and it fixed the issue.

2. Like someone mentioned all bay doors must be closed if there are switches on the bay doors.  Mine dies not.

3. In the rear bedroom fuse and circuit breaker panel there is another blade fuse there.


I hope this all helps.



20230829_231339 (2).jpg


Link to comment
Share on other sites

Thanks Gary. Wow, a fellow New Orleanian and a Cheetah owner. Thought I was the only one for miles. John commented yesterday about the engine on and I am 98% sure that was the issue. I was running around trying to winterize, exercise the Engine and Genny (just realized I forgot to drain the washer lines) prep the batteries and all. The engine was probably running when I tried to move out the bedroom slide to access the back bath. PM me if you ever want to get together and exchange war stories,

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...