Jump to content

Aqua Hot heat registers will not stay on


Recommended Posts

I woke up during the night and did not have any heat except for the floor heat under the kitchen sink and it was blowing hot (it is operated by a separate switch).  Checked the 5 button controller and all zones were on furnace.  It was only 40 degrees last night so the diesel was off.  I turned the diesel on and they all came on for a minute or so then quit blowing again.  I unplugged the cable from the controller and plugged back in.  Then tried to turn on the heat pumps and the won't come on either.  Yesterday all was working fine including the air conditioners.

I turned the Aqua hot diesel switch off and waited awhile and turned it back on and the blowers all came on for about 7-10 minutes and shut down again.  They all came on and went off at the same time

 

What am I missing, I remember at one time you could reset the 5 button controller but can't remember how.

Link to post
Share on other sites

Reset the Dometic Comfort Control thermostat by sliding the black switch on the bottom to off.  Then while holding both the top and bottom buttons down, slide the switch on.  You will see FF in the display.  

From your description it's difficult to tell what's wrong.  First, when you turn on the Aqua Hot diesel switch do you hear the diesel burner light and run for about 20 min? 

Also, to heat the entire coach in cold weather will require the diesel burner.  The electric Aqua Hot is only for small heating situations or a small amount of hot water.  

The heat pumps work well down to about 40 degrees.  Below that they loose efficiency and the coils begin to freeze up.  

 

Edited by vito.a
Link to post
Share on other sites
34 minutes ago, vito.a said:

Reset the Dometic Comfort Control thermostat by sliding the black switch on the bottom to off.  Then while holding both the top and bottom buttons down, slide the switch on.  You will see FF in the display.  

From your description it's difficult to tell what's wrong.  First, when you turn on the Aqua Hot diesel switch do you hear the diesel burner light and run for about 20 min? 

Also, to heat the entire coach in cold weather will require the diesel burner.  The electric Aqua Hot is only for small heating situations or a small amount of hot water.  

The heat pumps work well down to about 40 degrees.  Below that they loose efficiency and the coils begin to freeze up.  

 

I did not go outside to hear the diesel fire up but it must be working as we have very hot water and the one register under the sink is blowing very hot air.  I don't think it is the 5 button controller as I can switch to heat pumps.  But will reset set any way.  Thanks for instructions.

Link to post
Share on other sites
4 hours ago, philcarrell said:

I did not go outside to hear the diesel fire up but it must be working as we have very hot water and the one register under the sink is blowing very hot air.  I don't think it is the 5 button controller as I can switch to heat pumps.  But will reset set any way.  Thanks for instructions.

The diesel burner came on.  I did a reset of the 5 button controller all zones came on for a few minutes then went off

 

Link to post
Share on other sites

You will hear the diesel burner inside the coach when it's running.  If you are on electric only, you will get a small amount of hot water and a limited amount of coach interior heating.

You should turn on the Aqua Hot diesel switch inside the coach (probably in the kitchen) and hear the diesel burner light. First you will hear the pump spin up, then after about 20 seconds you will hear the burner light. It will sound like a small jet engine and the Aqua Hot exhaust pipe will blow out very hot exhaust. Hopefully it has been serviced. If not it can smoke badly.
The diesel burner will run for about 20 min and then first the burner will shut down and it will go into the cool down cycle for 1-2 min and finally shutdown and all will be quiet until the system demands more heat.

Edited by vito.a
Link to post
Share on other sites

Thanks I am familiar with thye diesel operation.  Imdid start it several times and nothing changed.  I was having an issue with Inverter so I turned off the Inverter breakers and turned back on and the aqua hot has been working OK since then.  Have no idea what this had to do with it.  Will follow up tomorrow

Link to post
Share on other sites

I had a similar issue and eventually  found the coupler for the data (phone) lines up in the ac units that connect  the wall thermostat to the units had deteriorated and was messing up the signals. Cleaned the jack ends and installed new couplers and problem went away. I would check there.

Roy  

2003 Dynasty

 

Link to post
Share on other sites
9 hours ago, miacasa_2000 said:

I had a similar issue and eventually  found the coupler for the data (phone) lines up in the ac units that connect  the wall thermostat to the units had deteriorated and was messing up the signals. Cleaned the jack ends and installed new couplers and problem went away. I would check there.

Roy  

2003 Dynasty

 

I second this suggestion.  At least unplug/replug the data connector several times.  I had a similar issue with a heat pump cycling every couple of minutes and repluging the connection fixed it.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...