Jump to content

stop engine light comes on


Recommended Posts

Hello everyone,How does one go about retrieving er codes , every week when i leave home after about 1 mile the stop engine light comes on and the motor goes into reduced power so i pull over and by the time i get stopped it goes out and all is well and never comes back on  for the rest of the 60 mi trip when i head for home it comes back on , All gauges and fluids are fine.  07 monaco dynasty isl400.

Link to comment
Share on other sites

Hi Donnie,

Not sure if yours I’d like mine.  On my 2008 Dynasty on the left lower dash I have a set of push buttons to select what is displayed such as PSI, FUEL ETC.  One of them is Diag.  With the engine running push this button then select engine and it will run a diagnostic and return error codes if they exist.

 

gary

  • Like 1
Link to comment
Share on other sites

You probably have the Medallion System. I believe there is a manual in the download section. This is the selector panel.

1CA2F1E4-B9F8-4469-A566-60B70A829CF3.jpeg

Link to comment
Share on other sites

2 hours ago, D.Ellison said:

i dont have that panel but i thought i had seen something like what your describing on my speedometer head display

 

I looked in your manual and u may have the Aladdin System. If you have the Aladdin manual, you might read up on it. I know nothing about that system. It may have a joystick with it somewhere.

Link to comment
Share on other sites

My Aladdin does not have a diagnostic section. You may have to have a Cummins service center plug into your diagnostic port to retrieve the code

Edited by Chargerman
Link to comment
Share on other sites

i checked last night and there is a diagnostic readout on the gauge cluster  i scrolled to engine diagnostics and there was no fmi codes present , so i dont know if the problem maybe wasnt stored  and can only be read while active which is driving down the road ,,,thats not good lol.

on another note, i could select engine diagnostic sitting in my driveway before i leave take off and im sure within 1 mile the stop engine light will be on 

Link to comment
Share on other sites

I would suggest you get a Scan Gauge D. It just connects to the diagnostics plug which is usually located below the dash on the left side of the steering column. It does many things. You can read and clear codes with it. They can be bought on line for under 200.00. Cheaper than a one trip to Cummins.

19C03884-87A4-4992-A74A-8810081DC58F.jpeg

Link to comment
Share on other sites

I had similiar problem the word FAILURE came on the face of the speedmeter.Came on after about 50 miles went out ,50 miles later came back on and shortly after engine stopped  [ISL 400].Problem was back in the Big Boy compartment upper left corner green plastic connector block with white wires connected to it [ground block]Two loose wires to eci on engine were loose .Tightened, all was good. Lucky find.

Link to comment
Share on other sites

i purchased this coach last fall late and drove it 900 miles home without a glitch took it to the track pulling my enclosed trailer twice all was good stored it over the winter and this spring everytime its shutoff for a few hrs then start out within 1 mile stop engine comes on  then goes into reduced power so i pull over and usually just about the time i get stopped it goes out and away we go , Sunday am leaving the track i made it to a downhill incline  when i felt it go into reduced power i eased off the fuel rode it down the hill and it went out without pulling over

Link to comment
Share on other sites

Possibly time for fuel filter change?Same symptoms I have w/04 Diplomat. Been chasing a bad fuel/algae problem .Change filters no problem till plugged up again ...the good news is I.m getting more miles between filter changes!  Two great additives help the problem.Biobor and Star Tron Enzyme fuel Treatment additive,Tom Cherry recommended the addittion of Star Tron,great stuff .it allows sub-micron debris to be safely eliminated as engine runs.Together they work great,I use them as preventive maintenance rather than when needed as then it is a bigger problem.Hope this helps your situation as it has mine. There is nothing like the feel of a dead accellerator and looking in rear view mirror to see Black Smoke  knowing ya gotta get over and change a filter! Sometimes I have gotten lucky,pulled off and when tank settles(pickup tube) clears and all back to normal.Just a reminder to driver "You are on borrowed time,look for a safe place to pullover and change it up!"Hope this helps!

Bruce Crocker

2004 Diplomat40'PDQ

Link to comment
Share on other sites

When I first bought our coach I was changing the fuel filters and there was  heavy layer of black slime almost clogging the primary filters, CRAP I've got Algae!!

I had not noticed any power or performance issues.  I did some research and started to used both Biobor and Startron enzyme treatment.  When I store the coach for a long period I fill the tank full (up to the filler neck dribbling out) and then add both of the above >>> leave it and forget it.  Never had a problem after that.

Our last long trip was late 2015 and after that I was up to my neck in building a new house.  Last year (YES, +5 years later) I started siphoning fuel out of the tank using it in my tractor, never saw any signs of algae.   Then late last year I filled my tank with 85 gallons of fuel drove it ~75 miles without a problem.  Finally took it last week on a trip and it did great. 

Link to comment
Share on other sites

  • 8 months later...
Guest bobstromain

I discovered the algae doing a routine fuel filter change.  I had never had this problem before.  After I changed the filters They stopped up again in 65 miles.  Consulted the group and was advised to shock with A product called Clear Diesel followed with shock and maint. treatments with Biobar JF and a third product Diesel Kleen.  I Followed the directions and drove the coach almost daily I changed filters Seven times and drove over 1,000 miles until the filters were clean.  I add a maint. dose every other fill up.  that was over a year ago  

Bob St. Romain

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...