Jump to content

Cruise control problem


Recommended Posts

04 Dynasty,  400 ISL, Today while traveling in NC, the cruise control stopped working. Pushed SET again and it worked for less than a minute. Shutoff cruise and tried again to no avail. Now it won't engage at all but light on dash says it's on. Jake is off....anyone ever experience this before?

Link to comment
Share on other sites

Any chance the ATC light is flashing? 

Just a hunch . . . . maybe barking up the wrong tree (turned out to be a clogging fuel filter / ISC engine).  My cruise was downshifting the transmission, but cruise stayed engaged.  Early symptom was a ATC light flashing. 

- bob

 

Link to comment
Share on other sites

I would check and clean the contacts for your steering wheel system. If you have a slip ring in your steering wheel like I do that was my problem when the crews kept shutting off

Link to comment
Share on other sites

Check that all the functions of the Smart wheel work…some may not. If not, start with the plug at the base of the steering column…remove and clean.

There is a Smart wheel troubleshooting procure using a blinking led on the controller in the FRB…takes two people.

While looking at the controller, check for a burnt headlight plug.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...